AMIRIS / amirispy installation is not working properly – who experienced similar problems?

Unfortunately, I did not get AMIRIS to run properly.

After installation of the program with amirispy and download of Amaris examples folder, I always get the following error code:

*FileNotFoundError: [Errno 2] No such file or directory: 'java -cp "/content/amiris-core_1.2.3.3-jar-with-dependencies.jar" "-Dlog4j.configuration=file:/content/" de.dlr.gitlab.fame.setup.FameRunner -f "/content/input.pb" -s "/content/fameSetup.yaml“*

Who experienced similar problems - or who could help on this?

Thanks in advance for any feedback,


Operating systems and software versions used:

  • Operating system: Mac OS (Catalina, Version 10.15.7)
  • The path to jar and scenario.yaml is correct, files are existing
  • Python Version 3.8.3 is installed, using Anaconda platform
  • Java is installed (openjdk Version „11.0.17“ )

Hi Robert,

could you please also paste your full console command that leads to this error?
Have you checked that you started from the correct path in your console, since the error log shows relative paths?


Dear Felix,

Thanks for the quick response.

I checked the path and could not find any problem. Furthermore, I tested two versions of AMIRIS ( and and different examples files.

In particular, I tried to run it on two different operating systems (Mac OS and Linux). Unfortunately, I experienced always the same error code.

Please find following the command lines.

Thanks for you advice,
kind regards,

Mac OS:

!amiris run -j /content/amiris-core_1.2.3.4-jar-with-dependencies.jar -s /content/examples-main-Germany2019/Germany2019/scenario.yaml


FileNotFoundError: [Errno 2] No such file or directory: ‘java -cp “/content/amiris-core_1.2.3.4-jar-with-dependencies.jar” “-Dlog4j.configuration=file:/content/” de.dlr.gitlab.fame.setup.FameRunner -f “/content/input.pb” -s "/content/fameSetup.yaml“’



!amiris run -j /Users/robert/amiris-core_1.2.3.3-jar-with-dependencies.jar –s /Users/robert/examples/Simple/scenario.yaml –o simple


FileNotFoundError: [Errno 2] No such file or directory: ‘java -cp "/Users/robert/amiris-core_1.2.3.3-jar-with-dependencies.jar“
de.dlr.gitlab.fame.setup.FameRunner -f “/Users/robert/input.pb” -s

@robertH: Some of your command line “dashes” are actually unicode U+2013 chars. Try replacing them with ASCII “dashes” U+002D. (Otherwise this might just be a transcription issue related to your posting.)

I assume that you are using some kind of browser-based computing environment (e.g. Google Colab, Jupyter Notebook, etc.). Our wrapper amirispy is currently only tested on the system console.

If you cannot use the console of your system, you may use the following three commands (after you have executed the amiris install command) as a workaround to

1. compile your scenario input.pb

!makeFameRunConfig -f scenario.yaml -o input.pb

2. execute AMIRIS

!java -cp amiris-core_1.2.3.4-jar-with-dependencies.jar de.dlr.gitlab.fame.setup.FameRunner -f input.pb -s fameSetup.yaml

3. convert the results to human-readable csv files

!convertFameResults -f output.pb

As always, adapt the paths in the commands if necessary.

Hi Felix,

Thanks a lot for you advice.

This workaround goes into the right direction. After calling the program through the proposed java command line, the jar file could be found and Amiris seems to start correctly.

However, an important step in this workaround seems to be missing because no input.pb and files are generated. Therefore, the calculation is aborted.

In constrast, if I am running first

!amiris run -j /content/amiris-core_1.2.3.4-jar-with-dependencies.jar …

the input.pb file is generated (even if the calculation is aborted at a late stage). With this input.pb file in the working directory it is possible to run amiris and generate the output folder. Nevertheless, this do not lead to proper results (not surprising, because of missing data in

Which command lines should be added to generate the missing files (input.pb, log4j.proberties)? Unfortunately I could not find sufficient information in the amiris wiki.

Thanks in advance, kind regards, Robert

I have noticed a minor inconsistency in my previous post.
Therefore, I have updated the instructions by naming the file to create input.pb (default: config.pb):

!makeFameRunConfig -f scenario.yaml -o input.pb

The file is downloaded (together with fameSetup.yaml, and the amiris.jar files) when executing amirispys’ amiris install. This command is executed only once in order to setup your amiris installation properly.

With AMIRIS version the java command is simpler and now reads:

!java -jar amiris-core_1.2.3.4-jar-with-dependencies.jar -f input.pb

See also the updated AMIRIS Getting started Guide

1 Like

Hello @robertH,

we have fixed a bug in amirispy which most certainly resolves your issue.

Please consider updating to amirispy 1.1.1 via

pip install amirispy==1.1.1